Android Geräte werden disconnected

Allgemeine Fragen zu Themen die sonst nirgendwo passen

Moderator: Lancom-Systems Moderatoren

Antworten
DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Android Geräte werden disconnected

Beitrag von DirkK »

Hallo,

ich habe zur Zeit ein massives Problem mit Geräten auf Android-Basis.
Ich habe zwei Netatmo-Netzwerkkameras auf Android-Basis, welche Jahrelang mehr oder weniger problemlos mit meinen Lancom Accesspoints verbunden waren.

Seit einigen Monaten (3-4?) fliegen sie aber immer wieder aus dem WLAN raus und zwar so heftig, dass sie danach auch nach einer Stromnetztrennung und einem Reboot des WLC und der AP's nicht mehr ins LAN kommen. Im LAN-Monitor sehe ich zwar, dass sie sich mit der entsprechenden SSID verbinden, aber keine IP mehr von dem DHCP-Server in meinem WLC (1784) mehr zugewiesen bekommen. Keine Chance mehr mit normalen Mitteln die ins Netz zu bekommen.
Abhilfe schafft nur, wenn ich eine Fritzbox, eingerichtet mit identischer SSID und Passwort temporär anschalte, die Kameras dann neu auf dieses FB-WLAN anmelde, dann die FB abstecke und die Kamera dann wieder an ihren Bestimmungsort (mit Lancom-WLAN-Abdeckung) verbringe, dann werden sie zum einen wieder mit der SSID verbunden und erhalten dann auch wieder eine IP vom WLC.
Da das ganze mittlerweile aber mehrfach wöchentlich passiert muss nun eine Lösung her.

Des weiteren ist ein ähnliches Verhalten beim Galaxy-A50 einer Freundin zu beobachten: Das Galaxy war per "Benutzer-Authentifizierung über MAC-Adresse" am Public-Spot des WLC's berechtigt. Das hat ebenfalls monatelang problemlos funktioniert, doch seit letzten Freitag erfolgt auch für dieses Galaxy keine IP-Adressvergabe mehr durch den DHCP des WLC. Das Galaxy meldet sogar "IP-Adresse konnte nicht bezogen werden". Ich habe dann mal eine fixe IP im Public-Spot-Bereich in das Galaxy eingetragen selbst dann lässt der WLC keinerlei Verbindung für das Galaxy zu.
Das Galaxy funktioniert aber an anderen WLANs oder auch Hotspots problemlos.

Es ist echt zum Verzweifeln, wie gesagt ein Reboot von WLC und AP's bringt keinen Erfolg. Gibt es irgendwelche Sperrlisten, wo die Geräte eingetragen sein könnten (aus welchem Grund auch immer). Das gibt es ja nicht dass monatelang einwandfrei funktionierende Geräte auf einmal komplett ausgesperrt werden.

Bin für jeden Hinweis dankbar

Grüße
Dirk

ua
Beiträge: 490
Registriert: 29 Apr 2005, 12:29
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von ua »

Hi,

was im Netzwerk hast Du geändert?
Wenn nicht, was genau nicht?
Updates auf den Clients durchgeführt?

VG
... das Netz ist der Computer ...
n* LC und vieles mehr...

DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DirkK »

ua hat geschrieben:
11 Mär 2020, 19:02
was im Netzwerk hast Du geändert?
Den einen oder anderen Client dazugefügt oder alte Geräte entfernt.
Eine eigene SSID für die Netzwerkkameras eingeführt, um die Probleme einzugrenzen und in den Griff zu bekommen; die Situation hat sich verbessert, aber wurde dadurch leider nicht wirklich gelöst.
ua hat geschrieben:
11 Mär 2020, 19:02
Updates auf den Clients durchgeführt?
Ja, darauf habe ich leider keinen Einfluss, weil das durch den Hersteller erfolgt.
Und ich habe natürlich auch die Firmware der AP's und des WLC jeweils upgedated. Das erscheint mir aktuell nämlich sogar das größte Problem! :twisted:
So bin ich vorhin von der 1784VA-10.40.0155 wieder zurück auf die 1784VA-10.40.0142-RC2 und siehe da, zumindest die Probleme mit dem Galaxy sind offensichtlich behoben. Seit Jahren gibt es immer wieder größere und kleiner Probleme mit DHCP-Server im LCOS, jetzt hat man es scheinbar wieder geschafft das Teil zu verkorksen...
Ich könnte echt kotzen... und ich suche mir hier stundenlang nen Wolf, woran das nun wieder liegen könnte.
Das Problem mit den Netzwerkkameras ist damit leider nicht vom Tisch, weil das bestand ja auch in der 1784VA-10.40.0142-RC2 und nein, es liegt nicht an Netatmo, denn mit einer FB als AP funktionieren die Dinger tadellos.

Grüße
Dirk

DanLo
Beiträge: 18
Registriert: 08 Jan 2019, 12:44
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DanLo »

DirkK hat geschrieben:
12 Mär 2020, 01:23
Seit Jahren gibt es immer wieder größere und kleiner Probleme mit DHCP-Server im LCOS, jetzt hat man es scheinbar wieder geschafft das Teil zu verkorksen...
Wie hast du verifiziert, dass es ein DHCP-Problem ist? Hast du das Problem schon als Bugreport bei LANCOM eingereicht?

DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DirkK »

DanLo hat geschrieben:
12 Mär 2020, 09:06
DirkK hat geschrieben:
12 Mär 2020, 01:23
Seit Jahren gibt es immer wieder größere und kleiner Probleme mit DHCP-Server im LCOS, jetzt hat man es scheinbar wieder geschafft das Teil zu verkorksen...
Wie hast du verifiziert, dass es ein DHCP-Problem ist? Hast du das Problem schon als Bugreport bei LANCOM eingereicht?
Ich habe einen DHCP-Trace gemacht und aus den DHCP-Responses habe ich dann daraus geschlossen, weil an den entscheidenden Stellen einfach 0.0.0.0 stand. Nein, habe ich nicht als Bugreport eingereicht.
:I) Mit der älteren Firmware geht es ja jetzt wieder ...

C/5
Beiträge: 33
Registriert: 18 Jul 2019, 10:55
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von C/5 »

Hallo zusammen,
vielleicht rührt das Problem daher, dass Android-Geräte ihre MAC-Adresse randomisieren? Das Galaxy A50 ist da ein guter genügend neuer Kandidat. Hängt davon ab, wie alt das Android ist und eventuell könnte man das Verhalten auch deaktivieren. Bei einer Antwort, inwiefern das für WLCs ein Problem sein könnte, muss ich allerdings mangels Wissen passen.
Gruß
C/5

Benutzeravatar
Jirka
Beiträge: 4721
Registriert: 03 Jan 2005, 13:39
Wohnort: Ex-OPAL-Gebiet
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von Jirka »

DirkK hat geschrieben:
12 Mär 2020, 01:23
So bin ich vorhin von der 1784VA-10.40.0155 wieder zurück auf die 1784VA-10.40.0142-RC2 und siehe da, zumindest die Probleme mit dem Galaxy sind offensichtlich behoben. Seit Jahren gibt es immer wieder größere und kleiner Probleme mit DHCP-Server im LCOS, jetzt hat man es scheinbar wieder geschafft das Teil zu verkorksen...
Ich könnte echt kotzen... und ich suche mir hier stundenlang nen Wolf, woran das nun wieder liegen könnte.
Dass das aber eine Beta-Version ist, die Du da installiert hattest, ist Dir schon bewusst? Und dass die RC2 ein Release-Candidate ist auch?
Ich kann Dir immerhin sagen, dass die Netatmo-Outdoor-Kameras mit der 10.12 (empfohlene Stable-Release) und der 9.24 (leider die letzte Firmware auf vielen APs) funktionieren. Die Netatmo-Wetterstationen auch, wobei die sich nach einem halben oder dreiviertel Jahr Dauerbetrieb irgendwie mal aufhängen.

Viele Grüße,
Jirka
15 Jahre LANCOM-Forum — 15 Jahre Kompetenz in Sachen LANCOM.

DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DirkK »

C/5 hat geschrieben:
12 Mär 2020, 12:40
vielleicht rührt das Problem daher, dass Android-Geräte ihre MAC-Adresse randomisieren? Das Galaxy A50 ist da ein guter genügend neuer Kandidat.
Also ich sehe im DHCP-Trace immer dieselbe MAC und gerade im Public-Spot WLAN sollte das ja kein Problem sein, dann sollte das Gerät jedenfalls trotzdem eine IP bekommen und danach die Public-Spot-Anmeledeseite.

Aber danke für die Anregung.

Grüße
Dirk

DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DirkK »

Jirka hat geschrieben:
12 Mär 2020, 15:04
Dass das aber eine Beta-Version ist, die Du da installiert hattest, ist Dir schon bewusst? Und dass die RC2 ein Release-Candidate ist auch?
Ich kann Dir immerhin sagen, dass die Netatmo-Outdoor-Kameras mit der 10.12 (empfohlene Stable-Release) und der 9.24 (leider die letzte Firmware auf vielen APs) funktionieren. Die Netatmo-Wetterstationen auch, wobei die sich nach einem halben oder dreiviertel Jahr Dauerbetrieb irgendwie mal aufhängen.
Hi Jirka,
ja, dass das Beta bzw. RC ist, ist mir voll bewusst, aber ich dachte die letzte Stable-Release für den 1784 ist die 10.32 (evtl. ein Typo von dir?).
Aber danke für die Info, dass es zumindest eine Version gibt, bei der das (noch) stabil funktioniert hat. Ich kann leider nicht mehr genau sagen, ab wann und mit welcher Firmware diese massiven Probleme aufgetreten sind. Vor allem ist es dann ja so schlimm, dass die Kameras überhaupt keinen Mucks mehr machen, bis man das Netzwerk neu einrichtet.
Das mit der Netatmo-Wetterstation habe ich auch schon so erfahren. Danke jedenfalls für den Informationsaustausch!

Viele Grüße
Dirk

DanLo
Beiträge: 18
Registriert: 08 Jan 2019, 12:44
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DanLo »

DirkK hat geschrieben:
12 Mär 2020, 17:20
Also ich sehe im DHCP-Trace immer dieselbe MAC und gerade im Public-Spot WLAN sollte das ja kein Problem sein, dann sollte das Gerät jedenfalls trotzdem eine IP bekommen und danach die Public-Spot-Anmeledeseite.
Hallo!

Kannst du den Trace mal posten (natürlich ggf anonymisiert)?

DirkK
Beiträge: 360
Registriert: 13 Jun 2005, 15:49
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von DirkK »

DanLo hat geschrieben:
13 Mär 2020, 13:36
Kannst du den Trace mal posten (natürlich ggf anonymisiert)?
Hi,

leider nicht, da das Galaxy gerade nicht mehr hier im Netz ist.

Grüße
Dirk

ittk
Beiträge: 1224
Registriert: 27 Apr 2006, 09:56
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von ittk »

Wenn Du erst ab LCOS 10.40 den "Fehler" hast, dann musst Du komplette Traces unter Angabe aller Rahmenbedingungen als Supportfall einreichen....
12x 1621 Anx. B-21x 1711 VPN-3x 1722 Anx. B-7x 1723 VoIP-1x 1811 DSL, 1x 7011 VPN-1 x 7111 VPN-1x 8011 VPN-10er Pack Adv. VPN Client (2x V1.3-3x 2.0)-Hotspot Option-Adv. VoIP Client/P250 Handset-Adv.VoIP Option-4x VPN-Option-2x L-54 dual-2x L54ag-2x O-18a

Benutzeravatar
Jirka
Beiträge: 4721
Registriert: 03 Jan 2005, 13:39
Wohnort: Ex-OPAL-Gebiet
Kontaktdaten:

Re: Android Geräte werden disconnected

Beitrag von Jirka »

DirkK hat geschrieben:
12 Mär 2020, 17:28
aber ich dachte die letzte Stable-Release für den 1784 ist die 10.32 (evtl. ein Typo von dir?).
https://www.lancom-systems.de/produkte/ ... ebersicht/
15 Jahre LANCOM-Forum — 15 Jahre Kompetenz in Sachen LANCOM.

Antworten
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag

Zurück zu „LANCOM: Allgemeine Fragen“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 54 Gäste