Deinstallation von PCI-54ag killt WinXP

Forum zu LANCOM AirLancer: MC-11, PCI-11, MC-54ab, PCI-54a, MC-54ag, PCI-54ag, USB-11, USB-54ag und PCI-54pro, USB-300agn

Moderator: Lancom-Systems Moderatoren

Antworten
wireless_lan
Beiträge: 50
Registriert: 03 Jan 2005, 00:17
Kontaktdaten:

Deinstallation von PCI-54ag killt WinXP

Beitrag von wireless_lan » 12 Jan 2006, 00:33

Hi,

ich muss mal testweise meine PCI-54ag aus winxp sp2 entfernen. Natürlich habe ich den neuesten Lancom-Treiber. Deinstalliere ich die Karte, dann kommt beim Neustart kein Anmeldeschirm mehr, stattdessen fehlt wohl eine athgina.dll und ich soll das System neu starten. Erst über abgesicherten Modus und Systemwiederherstellung bekomme ich das Sytem wieder in Griff. Hat jemand eine Idee, wie ich die Lancom-Karte da sauber herausbekomme?

wireless_lan

froeschi62
Beiträge: 985
Registriert: 13 Dez 2004, 11:44
Kontaktdaten:

Beitrag von froeschi62 » 12 Jan 2006, 01:00

Hallöchen,

WinXP im abgesicherten Modus starten und nachfolgendes Tool anwenden.

Gruß
Dietmar
Dateianhänge
XP_FixLogon.zip
(10.5 KiB) 1177-mal heruntergeladen

Benutzeravatar
filou
Beiträge: 1199
Registriert: 01 Mär 2005, 18:32
Wohnort: Mont de Cerf
Kontaktdaten:

Beitrag von filou » 12 Jan 2006, 01:12

Hallo wlan,

da wurde wohl die msgina.dll, die zum Logon gebraucht wird mit der athgina.dll ausgetauscht, auf die nach der Deinstallation der Karte nicht mehr zugegriffen werden kann, weil nicht geladen.

Noch ein Tipp-Link zum Reinstall der msgina.dll->
http://www.windows-tweaks.info/html/msgina-a.html
Gruß
Jens

...online mit 1784VA (VDSL 100) + WLC-Option
WLAN mit L-1302 / L-1310 / OAP-830
LAN über GS-1224

wireless_lan
Beiträge: 50
Registriert: 03 Jan 2005, 00:17
Kontaktdaten:

Beitrag von wireless_lan » 13 Jan 2006, 14:21

vielen Dank für eure Tipps. Hat einwandfrei funktioniert. :D

wireless_lan

Benutzeravatar
filou
Beiträge: 1199
Registriert: 01 Mär 2005, 18:32
Wohnort: Mont de Cerf
Kontaktdaten:

Re: Deinstallation von PCI-54ag killt WinXP

Beitrag von filou » 21 Jan 2006, 11:01

kommt beim Neustart kein Anmeldeschirm mehr, stattdessen fehlt wohl eine athgina.dll und ich soll das System neu starten.
Mir ist es genauso ergangen am W2K-Notebook, nachdem ich die Airlancer-Software über Systemsteuerung/Software/Entfernen deinstalliert habe, da ich diese aufgrund der nicht funktionierenden Domänenanmeldung, testweise neu installieren wollte.

Ich habe mich danach als lok. Admin über abgesicherten Modus neu angemeldet und die Airlancer-Software neu installiert (was ich ja sowieso vor hatte), was das System wieder startfähig machte.

Das halte ich aber nun wirklich für einen kritischen Bug in der Deinstallationsroutine der Treibersoftware :x
Gruß
Jens

...online mit 1784VA (VDSL 100) + WLC-Option
WLAN mit L-1302 / L-1310 / OAP-830
LAN über GS-1224

Benutzeravatar
const
Moderator
Moderator
Beiträge: 13
Registriert: 19 Feb 2005, 18:38
Kontaktdaten:

Beitrag von const » 10 Nov 2006, 18:09

@filou:
Der von Dir verlinkte Artikel läßt leider völlig außer Acht, dass Windows nur dann die msgina.dll verwendet, wenn im Registry-Schlüssel HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon der Eintrag GinaDLL fehlt. Ansonsten wird ohne Fallback versucht, die dort angegebene und evtl. schon nicht mehr vorhandene DLL zu laden.
Es reicht also meist (da die original DLL im oben beschrienbenen Szenario meist nicht kaputt oder weg ist), diesen Wert in der Registry im abgesicherten Modus zu löschen.

BTW.:
Das LANCOM AirLancer Setup restauriert bei der Deinstallation in der Registry diejenige GINA-DLL, welche vor der Installation dort eingetragen war. Leider ließ sich das oben beschriebene Problem noch nicht zuverlässig nachstellen, um es zu beseitigen :(

Antworten

Zurück zu „LANCOM AirLancer: MC-11, PCI-11, MC-54ab, PCI-54a, MC-54ag, PCI-54ag, USB-11, USB-54ag und PCI-54pro, USB-300agn“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast