SIP-ALG Problem nach re-invite

Forum zu LANCOM Systems VoIP Router/Gateways und zur LANCOM VoIP Option

Moderator: Lancom-Systems Moderatoren

Antworten
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

SIP-ALG Problem nach re-invite

Beitrag von equaL »

Ein freundliches Hallo in die Runde,

leider habe ich seit dem Update meines 1781VAW auf LCOS 10.42RU2 ein Problem mit der SIP-ALG Funktion.

Ich betreibe die folgende Konfiguration:

Telekom VDSL mit SIP Telefonie
(VDSL2)
1781VAW (LCOS 10.42RU2) mit SIP-ALG
(ETH)
1722VoIP (LCOS 9.00SU8) mit VCM
(ETH)
IP Telefone (Gigaset/CISCO/Snom)

Das Problem ist eine einseitige Sprachverbindung welche reproduzierbar nach 15 Minuten den RTP Stream Provider > Initiator betrifft. (Also: Ich rufe jemanden an, unterhalte mich, nach 15 Minuten höre ich meinen Gesprächspartner nicht mehr, er mich aber schon.)

Ok, da war doch was mit dem Telekom typischen re-invite nach 15 Minuten. Da hatte ich schon mal von gelesen, aber dort war die ganze SIP Session nach 15 Minuten ausgelöst worden. Die bleibt bei mir aber stehen. Also habe ich von der Verbindung einen Trace aufgezeichnet. Ergebnis:

Nach 15 Minuten kommt tatsächlich ein re-invite vom Provider. Mit einem „SIP OK 200“ Paket teilt der SIP-ALG in der SDP Section einen neuen RTP/UDP Port mit. Der wird aber in der Folge vom SIP-ALG ignoriert, denn die RTP/UDP Pakete vom Provider an diesen neuen Port führen zu ICMP Port unreachable Meldungen.

Eine Lösung für mein Problem ist natürlich ein Downgrade auf LCOS 10.40RU3. Das kann aber nur eine temporäre Lösung sein.

Ist es möglich das sich hier noch ein Konfigurationsfehler meinerseits auswirkt?
Tritt das Problem auch mit anderen SIP PBX auf?

Code: Alles auswählen

[SIP-ALG-Packet] 2021/04/13 14:45:37,903  Devicetime: 2021/04/13 14:45:37,483 [PACKET] : 
Sending datagram with length 822 from 217.253.122.224:9663 to 217.0.27.32:5060
SIP/2.0 200 OK\r\n
Via: SIP/2.0/UDP 217.0.27.32:5060;branch=z9hG4bKg3Zqkv7irkn7cwrde6i9zux5qhdorfyl8\r\n
From: <sip:0201xxxxxx@tel.t-online.de;user=phone>;tag=h7g4Esbg_p65551t1618317035m776178c32940s1_3423416470-939399495\r\n
To: <sip:0201xxxxxx@tel.t-online.de;user=phone>;tag=1046857350--947003614\r\n
Call-ID: 2267684619@00a05711a914\r\n
CSeq: 3 INVITE\r\n
Max-Forwards: 70\r\n
User-Agent: SL450A GO/42.254.00.000.000\r\n
Server: voip.xxxxxx.de\r\n
Allow: REGISTER, INVITE, ACK, CANCEL, BYE, REFER, NOTIFY, OPTIONS\r\n
Contact: <sip:0201xxxxxx@217.253.122.224:9663>\r\n
Content-Type: application/sdp\r\n
Content-Length: 223\r\n
\r\n
v=0\r\n
o=- 2131410297 2131410297 IN IP4 217.253.122.224\r\n
s=call\r\n
c=IN IP4 217.253.122.224\r\n
t=0 0\r\n
m=audio 22854 RTP/AVP 8 101\r\n
a=rtpmap:8 PCMA/8000\r\n
a=rtpmap:101 telephone-event/8000\r\n
a=fmtp:101 0-16\r\n
a=sendrecv\r\n
a=ptime:20\r\n

[IP-Router] 2021/04/13 14:45:37,919  Devicetime: 2021/04/13 14:45:37,485
IP-Router Rx (LAN-1, INTRANET, RtgTag: 0): 
DstIP: 217.0.6.53, SrcIP: 192.168.100.10, Len: 200, DSCP: EF (0x2e), ECT: 0, CE: 0
Prot.: UDP (17), DstPort: 63556, SrcPort: 39376
Route: WAN Tx (T-ONLINE)

[ICMP] 2021/04/13 14:45:37,919  Devicetime: 2021/04/13 14:45:37,491
ICMP Tx (WAN, T-ONLINE): Dest-IP: 217.0.6.53: Destination unreachable (Port unreachable)
original packet:
DstIP: 217.253.122.224, SrcIP: 217.0.6.53, Len: 200, DSCP: EF (0x2e), ECT: 0, CE: 0
Prot.: UDP (17), DstPort: 22854, SrcPort: 63556
Gruß aus Essen … Erik
Zuletzt geändert von equaL am 13 Apr 2021, 17:15, insgesamt 1-mal geändert.
ua
Beiträge: 578
Registriert: 29 Apr 2005, 12:29

Re: SIP-ALG Problem nach re-invite

Beitrag von ua »

Hi,

normalerweise sollten die Telefone an einem DTAG-AS auch ohne ALG funktioniern.
Ggf. den UDP-Timeoute auf 481s einstellen.

VG
... das Netz ist der Computer ...
n* LC und vieles mehr...
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

Re: SIP-ALG Problem nach re-invite

Beitrag von equaL »

Hi ua (unnumbered ack?),

ich konnte mir nicht vorstellen wie das funktionieren kann, habe es aber ausprobiert. Ergebnis: Der VCM sendet seine private Adresse im Via und im Contact Header und bekommt ein Forbidden zurück.

Hat der VCM vielleicht eine STUN Funktion welche mir bisher entgangen ist? (Seitdem Lancom einen ALG hat, habe ich mich nicht mehr mit STUN beschäftigt und habe das als echten Fortschritt empfunden.)

Gruß ... Erik
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

Re: SIP-ALG Problem nach re-invite

Beitrag von equaL »

Um dem Problem etwas näher zu kommen habe ich mir die Tabellen Verbindungsliste und UDP-NAT-TABLE vor und nach dem re-invite angesehen. Ergebnis:

Der vom ALG neu zugeordnete Port wird nicht in die Verbindungsliste aufgenommen.
Die WAN Adresse der alten Zuordnung in der UDP-NAT-TABLE wird auf 0.0.0.0 gesetzt.
Ausserdem entspricht der neue UDP Port welcher vom ALG zugeordnet wird, dem Map-Port des alten Eintrags in der UDP-NAT-TABLE.

Gruß ... Erik
ua
Beiträge: 578
Registriert: 29 Apr 2005, 12:29

Re: SIP-ALG Problem nach re-invite

Beitrag von ua »

Moin,
1722VoIP (LCOS 9.00SU8) mit VCM
Als ich würde den VCM (notfalls als reinen SIP-Proxy) des 1781 nutzen, ggf. den 1722 per SIP an den 1781 hängen.
In das andere "windige" Konstrukt investierte ich keine zusätzliche Zeit ...

Viele Grüße
... das Netz ist der Computer ...
n* LC und vieles mehr...
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

Re: SIP-ALG Problem nach re-invite

Beitrag von equaL »

Moin,

ich bin unsicher was Du mit "windig" meinst. Ok, der 1722 ist wahrscheinlich nicht mehr supported. Allerdings habe ich dort auch kein problematisches Verhalten feststellen können.

Der 1781 hat aus meiner Sicht ein Problem mit der Verwaltung der NAT Einträge durch den SIP-ALG. Und das erst nach dem Upgrade von 10.40RU3 auf 10.42RU2. Das ist etwas was ich als "windig" verstehen könnte.

Deinen Hinweis auf die Nutzung des VCM am 1781 kann ich leider nicht umsetzen. Diese Funktion hat mein 1781 nicht. Andererseites ist der ALG ein supportetes Feature welches für meine Zwecke völlig ausreichend ist. Ich fürchte, dass der Kostenstellenverantwortliche nicht zustimmen würde die All-IP Optionen zu kaufen, wenn die Ursache kein abgekündigtes Feature, sondern ein geändertes/fehlerhaftes Verhalten ist.

Ich habe noch mal einen Trace gestartet und folgendes festgestellt:

Nach dem ersten invite werden zwei Einträge in der UDP NAT Table eingerichtet. Die Port Nummern sind incrementiert. Der zweite Eintrag hat als WAN Adresse die 0.0.0.0 und der Handler ist nicht UDP sondern default. Der zweite Eintrag wird nicht verwendet. Der Provider versucht zwar die Kombination von Ports für seinen RTP Stream zu verwenden. Aber der Lancom antwortet mit Port unreachable. Daher werden die Ports der ersten NAT Regel (natürliche vice versa) für beide RTP Streams verwendet.

Nach dem re-invite wird die WAN Adresse der ersten NAT Regel auch auf 0.0.0.0 gesetzt. In der Folge werden alle Pakete des UDP Streams vom Provider zum Lancom vom Lancom verworfen und mit Port unreachable beantwortet.

Das ist ein Verhalten welches alle Benutzer des ALG Features treffen sollte.

Gruß ... Erik
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

Re: SIP-ALG Problem nach re-invite

Beitrag von equaL »

Hallo,

habe nun mit Downgrades das Auftauchen des Fehlers eingegrenzt:

10.42RU2 -> das Zusammenspiel SIP-ALG mit der UDP NAT Table funktioniert nach einem re-invite nicht mehr, der vom Provider kommende RTP Stream wird gedroped
10.42Rel -> ich konnte keinen Unterschied zur 10.42RU2 feststellen
10.40RU3 -> hier läuft der RTP Stream auch nach einem re-invite weiter - so soll es sein

Ich hoffe das Lancom daran arbeiten wird. Bei Interesse könnte ich Trace Ausgaben des Problems zur Verfügung stellen.

Gruß ... Erik
awi
Beiträge: 44
Registriert: 19 Jun 2013, 15:22

Re: SIP-ALG Problem nach re-invite

Beitrag von awi »

Hallo,

hierfür gibt es bereits einen Fix ab der 10.42.0555.
Auf dem FTP-Server liegt aktuell eine 10.42.0560.
Damit könnt ihr ja mal testen und berichten.

Gruß
Awi
equaL
Beiträge: 31
Registriert: 04 Nov 2010, 10:05
Wohnort: Essen

Re: SIP-ALG Problem nach re-invite

Beitrag von equaL »

Hallo Awi,

das kann ich bestätigen. Mit LCOS 10.42.0560 laufen beide RTP Streams nach dem re-invite weiter!

Super!

Gruß ... Erik
Benutzeravatar
langewiesche
Beiträge: 1251
Registriert: 27 Apr 2005, 11:28
Wohnort: Gevelsberg / Sprockhoevel im Ruhrgebiet
Kontaktdaten:

Re: SIP-ALG Problem nach re-invite

Beitrag von langewiesche »

Hallo Zusammen,
leider sind ja viele Geräte (ca 10) in den aktuellen Versionen nach RU3 raus. wie bekomme ich es da weg?
Gibts da noch ein fix für die alte Version?
Es gruesst Lars
--
Zwischen einen NAT-Router hinter einen Nat-Router und vor einen NAT-Router passt immer noch ein NAT-Router
Antworten

Zurück zu „Fragen zu LANCOM Systems VoIP Router“